Jump to content

Melted terminal components on Red Brick battery


Recommended Posts

Hi All,

 

I know this isn't really Steadicam related, but I was hoping I could draw on your experience and knowledge with this nasty situation.

 

We hired a RED from one of my freinds to use at the BSC show, and he has just told me that a terminal on the charger and on one battery has melted. I have seen no photos so im not sure exactly what he means, but he is saying hte plastic parts around the power terminals have melted and rendered the battery and charger useless, and it needs replacing.

 

Has anyone seen anything like this happen before? Ive not heard of or seen this problem before. Could it be a one off, or could it happen again?

 

Im not sure what happened, I didn't see or smell any smoke, or experience any problems with any of the batteries or the charger whilst we were changing or charging the batteries.

 

We were using the RED charger and the standard power cradle.

 

 

Any help would be great.

 

 

Pete.

Link to post
Share on other sites
I know this isn't really Steadicam related, but I was hoping I could draw on your experience and knowledge with this nasty situation.

 

We hired a RED from one of my freinds to use at the BSC show, and he has just told me that a terminal on the charger and on one battery has melted. I have seen no photos so im not sure exactly what he means, but he is saying hte plastic parts around the power terminals have melted and rendered the battery and charger useless, and it needs replacing.

 

Has anyone seen anything like this happen before? Ive not heard of or seen this problem before. Could it be a one off, or could it happen again?

 

Im not sure what happened, I didn't see or smell any smoke, or experience any problems with any of the batteries or the charger whilst we were changing or charging the batteries.

 

We were using the RED charger and the standard power cradle.

 

 

sounds like a cell reversed polarity and the charger isn't smart enough to recognize that and just keep pouring current into the battery

Link to post
Share on other sites

Hi

 

I've also seen this happen with a pag charger and pag battery (both less than 4 months old). The prongs on the charger had been slightly bent at some point, Meaning they were not making a good electrical contact. This caused arcing on the terminal causing it to heat up and melt the plastic surrounding the terminals on both the battery and charger. The charger eventually shut down as it sensed something overheating, pure luck really the temp sensor in the battery was just behind the terminal that was overheating.

 

I've heard and seen people having problems with V-lock batts having bad contacts. So many makers and each with varying tolerences. Only the other day I saw an issue with a batt/camera cutting out when tilting the camera up.

 

So another option is the batt or charger may have had a bent or distorted pin and or socket.

 

Regards

Ant

Link to post
Share on other sites
  • 3 weeks later...

Quick update, RED gave him a new charger (out of warranty) and the battery still works, even though the plastic is a bit distorted. The damage to the battery was not as bad as he made it sound. the plastic had just pitted in a bit around where the terminal was. Certainly looks unusual but it still works, and a new charger so I think it all ended nicely this time.

 

 

Thanks,

 

Pete.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...