Jump to content

Sign in to follow this  
Christopher Moone

Anton Bauer pass through plate

Recommended Posts

Had a strange thing happen the other day using the Anton Bauer plate on the back of a red to power the camera from my PRO. It was a Panavised Red with their power back and only one of the lights would turn on and the camera wouldnt power up. Volt meter was getting 14.8 volts from the sled through the plate and a dionic straight to the camera worked fine. Strange ghost in the machine as Ive used that plate countless times in the past. Tried different cables and even differ jumper block below. Any thought on why? Again, getting lots of power from the plate with a volt meter.

Share this post


Link to post
Share on other sites

There could be a a short somewhere that you can only detect when connected to the camera's chassis. That, or maybe you have a bad diode or other component that is showing the correct voltage but can't pass enough current to start the camera.

Share this post


Link to post
Share on other sites

Contact Carmine in Italy

Hi skilled electronic engineer.he does Arri, Red repair, and steady,follow focus, cables build and repair....

carmize@hotmail.it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Betz Tools for Stabilizers

    Paralinx LLC

    Omnishot Systems

    Media Blackout - Custom Cables and AKS

    Ritter Battery

    GPI Pro Systems

×