Jump to content

Recommended Posts

Hi everyone,

Been trying to find some info on Volt issues/problems, but couldn’t find anyone.. Either this is my lack of good search engine abilities showing (...;-)) or there’s just not much on the topic yet. -Because I doubt that operators haven’t had their issues with the Volt yet. 

I’m a Volt owner myself but as I’ve only had it for about a couple of months, I haven’t ran into any big issues with it yet. It “stalled” a couple of times when I was practicing, but I just turned it off and restarted it. But that can possibly be because of an unaligned gimbal handle to back of camera/top-stage at the 3 sec start up. 

I love Steadicam because the whole idea of it is mechanical, when we add electronics, no matter how expensive, no matter how new/old, which shape/brand(s), it is never about if it will break but when it will break/stop working/having issues/etc!...And if one doesn’t have a quite decent insight/knowledge about electronics, one are totally “lost” (at least if one relies too much on the given device) ! 

So, any which Volt issues/problems have you had until now?? Did it take time to solve etc? 

Share this post


Link to post
Share on other sites

I haven't had any real issues with mine yet. At least nothing that has taken it out of action. 

The roll pulley has had the side pop off of two of them now. The dolly grip or assistant docking wrong and it pops super easy. If the belt is aligned properly there really isn't a need for it anyway. 

 

The other slightly annoying thing that happened was an assistant was putting away the rig and the gimbal was pushed way up the post. The plastic of the volt ended up rubbing on the knurled knob of the tilt stage and getting all scratched up. All cosmetic, but still a bummer.

 

Electronically and mechanically where it counts its been rock solid.  And I can't imagine operating without it now. Ive been able to nail shots I couldn't have even dreamed of before. 

  • Like 1

Share this post


Link to post
Share on other sites

I've had mine go wild a couple of times, and powering off and back on solved it. It's a bit unnerving when it happens, but fortunately very rare.

  • Like 1

Share this post


Link to post
Share on other sites

Sometimes I can't get the vault to be level no matter how many times I trim it. What seems to work is cycling the power a few times, but under a time crunch, it could be very annoying. I just switch it off and operate normally but it's an issue that I've seen multiple times and I don't know what causes it.

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, Kevin Jacobsen said:

Sometimes I can't get the vault to be level no matter how many times I trim it. What seems to work is cycling the power a few times, but under a time crunch, it could be very annoying. I just switch it off and operate normally but it's an issue that I've seen multiple times and I don't know what causes it.

Kevin, sounds weird! 

Are you aligning the gimbal handle to the back of your camera? 

So, you mean if you’re turning on/off your power/batteries it sometimes helps? 

When I’m low on power I notice it won’t run at all, only lights are showing, no motors turning. Then I have to switch batteries, which solves it.

 

Share this post


Link to post
Share on other sites

Actually, I second that. I did a shoot on the beach yesterday and noticed that the horizon was just slightly off. It is tough to trim it to be level when it's just ever so slightly off like that. The manual says to click the trim button once to lock in the new setting, but I've found (maybe imagined) that it only works if you hold it down for a second. Still tricky to make very fine trim adjustments. I would love to have something like the motorized stage, where you could remotely dial in the trim. Or even just another dial on the control box that would let you adjust it manually.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...



  • Omnishot Systems

    Paralinx LLC

    Ritter Battery

    Betz Tools for Stabilizers

    Media Blackout - Custom Cables and AKS

×
×
  • Create New...